Ruby & Rails Compatibility Table

This is a short post to show the compatibility between Ruby on Rails and Ruby across different versions. In the process of upgrading really old applications to more modern versions of Ruby and Rails we have ran into a lot of these combinations.

Rails
Version
Required
Ruby
Version
Recommended
Ruby
Version
Required
Rubygems
Version
Status
6.1.0 >= 2.5.0 >= 1.8.11 Alpha
6.0.x >= 2.5.0 >= 1.8.11 Maintained
5.2.x >= 2.2.2 >= 1.8.11 Maintained for Security Issues
5.1.x >= 2.2.2 >= 1.8.11 EOL
5.0.x >= 2.2.2 >= 1.8.11 EOL
4.2.x >= 1.9.3 2.2 >= 1.8.11 EOL
4.1.x to 4.2.0 >= 1.9.3 2.1 >= 1.8.11 EOL
4.0.5 to 4.1.0.rc2 >= 1.9.3 >= 1.8.11 EOL
4.0.0 to 4.0.x >= 1.8.7 >= 1.8.11 EOL
3.2.22 to 3.2.22.5 1.8.7 2.2 >= 1.3.6 EOL
3.2.13 to 3.2.22.4 1.8.7 2.0 >= 1.3.6 EOL
0.8.0 to 3.2.13.rc2 1.8.7 >= 1.3.6 EOL

Need to Upgrade Rails?

If you want to upgrade Rails, check out our series of articles that cover from Rails 2.3 to Rails 6.0: Articles by FastRuby.io about Rails upgrades

If you don't have the time to do it yourself and you have a budget to hire our team, send us a message over here: Contact FastRuby.io

Feedback Wanted: Updates

If you find that this article has fallen out of date, feel free to make a comment for us to bring it up to speed. We will continue to update this article as new versions of Ruby and Rails are released.

Get the book