#34 Upgrade Ruby from 2.7 to 3.0; Upgrading Rails Workshop at RailsConf 2021

Happy Wednesday!

Here is issue #034 of our newsletter, where we collect news and tools that we find interesting for your Rails project.

1. Upgrade Ruby from 2.7 to 3.0: This article covers the most important aspects that you need to know to get to the latest version of Ruby. 💎

2. RailsConf Workshop | Upgrading Rails: The Dual-Boot Way: We're happy to announce that next month we'll be conducting a workshop at RailsConf. 🎉

3. Announcing Standard Ruby 1.0: The popular Ruby style guide, linter, and formatter just released version 1.0.0! ✌️

4. Rails 7 adds ActiveRecord::Relation#excluding: This is one of the latest changes that happened in the Rails repo.

5. Yukihiro Matsumoto: 'Do not fight developer instincts': A very interesting interview with Matz. It's also available in video format.

We hope you find these links useful. Feel free to forward it to your friends! ;)

Have a nice week!

The FastRuby.io team.

* Want to know what upgrading to 6.1 would require? Request an audit to find out what catching up will require.

* Already on 6.1? Check out our Stay Up To Date service so you can be ready for Rails 7.0.

We are hiring! We are looking for a Senior Rails Developer interested in joining a fully remote and collaborative team. Learn more at https://ombulabs.com/jobs. Come work with us!

Don't wait to bring your Rails application up to date.

We will get on a quick call and recommend a couple of options to start upgrading your Rails app.